rpct.net
当前位置:首页 >> AnDroiD stuDio问题:FAilED For tAsk ‘:App:Comp... >>

AnDroiD stuDio问题:FAilED For tAsk ‘:App:Comp...

build tools版本过低,现在已经是24.0以上了,需要执行SDK更新操作,更新完然后重新build一下

1.dexDebug ExecException finished with non-zero exit value 2 需要在gradle中配置下面的代码,原因是引用了多个libraries文件 defaultConfig { multiDexEnabled true } 2.Execution failed for task ':app:transformClassesWithJarMergingForDebug'.

应该是依赖库重复了,你查一下另外在 app 的build.gradle目录下 加入defaultConfig {multiDexEnabled true}

更新SDK,每次创建时选择当前安装过的SDK版本

可以试试下面的方法:1、直接从 http://services.gradle.org/distributions/gradle-1.6-bin.zip 下载gradle(如果出现连接有问题,可以尝试qq旋风或者迅雷的离线下载)2、解压gradle-1.6-bin之后为文件夹gradle-1.6,将其中的内容拷贝到$(android_studio)/plugins/gradle3、将gradle-1.6/lib下的gradle.jar拷贝到$(android_studio)/lib中4、重启android studio

编译器编译错误,代码错误,检查方法代码

aaptOptions { cruncherEnabled = false },apps的 build.gradle文件中,在android {}内加入如上代码

里面有Jar包冲突了 你排查下

你这有错误,当然运行不了了,检查下资源文件,应该是非法字符输入没注意.一般是xml 里输入格式错误等.

方法:把Top-level build file修改为这个样子build.gradle:// Top-level build file where you can add configuration options common to all sub-projects/modules.buildscript {repositories {jcenter()}dependencies {classpath 'com.android.tools.build:gradle:1.

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.rpct.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com